Opened 13 years ago

Closed 8 years ago

#838 closed enhancement (duplicate)

doctest runner should share SAGE initialization using fork()

Reported by: cwitty Owned by: failure
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: gfurnish Merged in:
Authors: Reviewers: David Roe
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

On my machine, every file that gets doctested takes 0.8s for initializing SAGE (before it even gets to running the tests). It would be nice if this overhead could be eliminated somehow; and I think it might be possible, by having a single process do the SAGE initialization, then fork() before doctesting a particular file. (This sort of architecture might also make it easier to implement #639.)

Change History (3)

comment:1 Changed 12 years ago by mabshoff

  • Cc gfurnish added

This is not a dupe of #4699, but seems closely related since -tp 1 would basically work that way.

Cheers,

Michael

comment:2 Changed 9 years ago by roed

  • Report Upstream set to N/A

This will be resolved by #12415.

comment:3 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers set to David Roe
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.