Opened 14 years ago

Closed 12 years ago

#825 closed enhancement (fixed)

extending % to more sage types

Reported by: mhampton Owned by: mhampton
Priority: minor Milestone: sage-3.3
Component: numerical Keywords: remainder
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Currently the following gives an error: 10.23 % 2 The % should be extended to handle more types.

Change History (6)

comment:1 Changed 14 years ago by mhampton

  • Status changed from new to assigned

comment:2 Changed 14 years ago by robertwb

And probably be placed into the coercion model as well (though this will be easier once cdef overrideable is in place).

comment:3 Changed 13 years ago by zimmerma

The remainder of floating-point numbers can be given a sense: see the C99 remainder function, and the corresponding mpfr_remainder in MPFR.

comment:4 Changed 12 years ago by AlexGhitza

  • Type changed from defect to enhancement

comment:5 Changed 12 years ago by zimmerma

#5132 is a duplicate of that ticket.

comment:6 Changed 12 years ago by mabshoff

  • Milestone changed from sage-wishlist to sage-3.3
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed via #5132 in Sage 3.3.alpha4.

Cheers,

Michael

Note: See TracTickets for help on using tickets.