Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8230 closed defect (duplicate)

Strange behaviour in addition from not recursively preparsing loaded files

Reported by: zimmerma Owned by: robertwb
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: coercion Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Hi, I found the following strange behaviour of the addition <int> + 1/2. I have a file MurphyE.sage which contains:

load E.sage

foo(2)

where E.sage contains:

def foo(K):
    for i in range(K):
       print i, i+1/2, type(i), type(i+1/2)

Then I get:

sage: load MurphyE.sage
0 0 <type 'int'> <type 'int'>
1 1 <type 'int'> <type 'int'>

Now if instead I replace load E.sage in my file by the content of the procedure foo, i.e.:

def foo(K):
    for i in range(K):
       print i, i+1/2, type(i), type(i+1/2)

foo(2)

then I get:

sage: load MurphyE.sage
0 1/2 <type 'int'> <type 'sage.rings.rational.Rational'>
1 3/2 <type 'int'> <type 'sage.rings.rational.Rational'>

which is the expected behaviour. Please can someone explain to me the first result? I forgot to say it is with Sage 4.3.

Change History (3)

comment:1 Changed 11 years ago by robertwb

Dupe of #6345

comment:2 Changed 11 years ago by ylchapuy

  • Resolution set to fixed
  • Status changed from new to closed

it seems to be fixed now.

comment:3 Changed 11 years ago by mpatel

  • Milestone changed from sage-4.5.3 to sage-duplicate/invalid/wontfix
  • Resolution changed from fixed to duplicate
  • Summary changed from strange behaviour to Strange behaviour in addition from not recursively preparsing loaded files

I'm closing this as a "duplicate" of #6345.

Note: See TracTickets for help on using tickets.