Opened 10 years ago

Closed 5 years ago

#8214 closed defect (duplicate)

Remove callable symbolic expressions

Reported by: burcin Owned by: burcin
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by delius)

From sage-devel:

On Sun, 7 Feb 2010 10:36:29 -0800 (PST)
Gustav Delius <gustav.delius@gmail.com> wrote:

> I wonder whether it would be possible to give a better error message
> when a user leaves out the multiplication operator in something like
> x(x+1). Perhaps somthing like: "Warning: you may have forgotten a
> multiplication operator."
> 
> Currently one gets the error message: "DeprecationWarning:
> Substitution using function-call syntax and unnamed arguments is
> deprecated and will be removed from a future release of Sage; you can
> use named arguments instead, like EXPR(x=...,y=...)". This error
> message is meaningful only to people who know the history of sage and
> know that there used to be a confusing shorthand notation that allowed
> something like x=a^2 to be interpreted as x(a)=a^2. I am glad that was
> deprecated, but I think that the deprecation warning should be
> preceeded by the warning about the possibility of a missing *.

Here is the thread:

http://groups.google.com/group/sage-devel/t/de97f91d548cc0ec

Incidentally, it's almost a year since this was deprecated, #5413. Maybe we can remove the deprecation message for good. :)

Change History (11)

comment:1 Changed 10 years ago by delius

  • Description modified (diff)

Burcin, I agree with your observation that the shortcut notation has now been deprecated for a long time. However the shortcut notation has not actually been disabled yet. Perhaps the warning should stay until that has happened.

comment:2 Changed 10 years ago by kcrisman

As to what the new message should be:

Maybe, but that message is not so helpful.  I guarantee you that you don't need to know the history of Sage to do

sage: f=x^2
sage: f(2)

and expect 4.  You just need to attend an insufficiently pedantic algebra or calculus lecture :)

comment:3 Changed 8 years ago by kcrisman

  • Summary changed from add better error message when symbolic expressions are called to Remove callable symbolic expressions

But definitely add some serious documentation in several spots people might look for why this is "wrong". If it is ;-)

See also this sage-devel thread, where the BDFL suggests it really is time to let it go.

comment:4 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:5 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:6 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:7 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:8 Changed 5 years ago by rws

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix

duplicate of #14270

comment:9 Changed 5 years ago by aapitzsch

  • Status changed from new to needs_review

comment:10 Changed 5 years ago by vdelecroix

  • Status changed from needs_review to positive_review

comment:11 Changed 5 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.