Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8165 closed defect (fixed)

Title cut off on worksheet download

Reported by: jason Owned by: was
Priority: major Milestone: sage-4.3.3
Component: notebook Keywords:
Cc: Merged in: sagenb-0.7.5
Authors: Mitesh Patel Reviewers: Rob Beezer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I just tried uploading the following worksheet:

http://sagenb.org/home/pub/1139/

by pasting the URL into the middle box of the upload page on a (fairly fresh) 4.3.1 install. When I opened up the worksheet on the local server, the title was cut off to be about 14 characters long. This is a bug.

Attachments (1)

trac_8165-download_ws_name.patch (960 bytes) - added by mpatel 11 years ago.
Don't use rstrip to chop '.sws'. sagenb repo.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by mpatel

Don't use rstrip to chop '.sws'. sagenb repo.

comment:1 Changed 11 years ago by mpatel

  • Authors set to Mitesh Patel
  • Status changed from new to needs_review

The problem is the use of str.rstrip in twist.Worksheet_download:

sage: '112 - 01 - Review.sws'.rstrip('.sws')
'112 - 01 - Revie'

The patch uses str.endswith and a slice, instead.

comment:2 Changed 11 years ago by mpatel

Related: #7663, #7924.

To review this, if you have the time, I suggest using the latest spkg at #8051.

comment:3 Changed 11 years ago by mpatel

  • Summary changed from title cuts off on worksheet upload to Title cut off on worksheet download

comment:4 Changed 11 years ago by rbeezer

  • Reviewers set to Rob Beezer
  • Status changed from needs_review to positive_review

I've reproduced the problem on 4.3.1, then applied the patch on top of sagenb-0.7.4.spkg and the title survives properly when saved to an sws file and subsequently loaded into a notebook.

Positive review.

comment:5 Changed 11 years ago by mpatel

  • Merged in set to Mitesh Patel
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:6 Changed 11 years ago by mpatel

  • Merged in changed from Mitesh Patel to sagenb-0.7.5
Note: See TracTickets for help on using tickets.