Opened 10 years ago

Closed 8 years ago

#8073 closed defect (duplicate)

deprecation version number should say "After version ..."

Reported by: jason Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: misc Keywords:
Cc: Merged in:
Authors: Reviewers: Volker Braun, Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The docs to misc/misc.py, deprecation() say to put the current version of Sage, but the message that is printed says that the function has been deprecated "Since Sage <version>". The "since" can be construed as >=, instead of just >. I suggest we change "Since" to "After" to make the meaning more clear.

Change History (3)

comment:1 Changed 8 years ago by kcrisman

  • Reviewers set to Volker Braun, Karl-Dieter Crisman
  • Status changed from new to needs_review

Superseded by #13109.

comment:2 Changed 8 years ago by kcrisman

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

comment:3 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.