Opened 11 years ago

Closed 11 years ago

#7968 closed defect (fixed)

doctest failure in heegner.py (Sage-4.3.1.rc0)

Reported by: GeorgSWeber Owned by: tbd
Priority: blocker Milestone: sage-4.3.1
Component: doctest coverage Keywords:
Cc: Merged in: sage-4.3.1.rc1
Authors: William Stein Reviewers: Craig Citro
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On cicero, Fedora 12, 32-bit, Pentium 4, and also on cleo, Red Hat Enterprise Linux Server 5.3, 64-bit, IA-64, as well as on Mac OS X 10.4, Core2Duo, 32 bit:

[mvngu@cicero sage-4.3.1.rc0]$ ./sage -t -long devel/sage-main/sage/schemes/elliptic_curves/heegner.py sage -t -long "devel/sage-main/sage/schemes/elliptic_curves/heegner.py" File "/tmp/mvngu/sage-4.3.1.rc0/devel/sage-main/sage/schemes/elliptic_curves/heegner.py", line 1486:

sage: s.cmp(0)

Expected:

-1

Got:

1

Attachments (1)

trac_7968.patch (864 bytes) - added by was 11 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by GeorgSWeber

Is this "just" some refactoring fallout? Anyone any ideas?? (Fixing the doctest by itself is obviously trivial ...)

Changed 11 years ago by was

comment:2 Changed 11 years ago by was

  • Milestone set to sage-4.3.1
  • Priority changed from major to blocker
  • Status changed from new to needs_review

comment:3 Changed 11 years ago by craigcitro

  • Status changed from needs_review to positive_review

Yep, this looks good. As William pointed out to me when I asked, the issue is just that the ordering is random -- so just having the doctest confirm that they're not equal is the right thing to do.

comment:4 Changed 11 years ago by rlm

  • Authors set to William Stein
  • Merged in set to sage-4.3.1.rc1
  • Resolution set to fixed
  • Reviewers set to Craig Citro
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.