Opened 11 years ago

Closed 10 years ago

#7887 closed enhancement (duplicate)

Fast function field arithmetic

Reported by: robertwb Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords:
Cc: roed Merged in:
Authors: Robert Bradshaw, David Roe Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Wrapping zmod_poly directly should be much faster than the current implementation of Frac(GF(p)t?)

See also #7585

Attachments (2)

7887-FpT.patch (27.5 KB) - added by robertwb 11 years ago.
7887-FpT-update.patch (58.9 KB) - added by robertwb 11 years ago.
apply on top of previous

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by robertwb

Changed 11 years ago by robertwb

apply on top of previous

comment:1 Changed 11 years ago by ylchapuy

I know it's way to early for review, but maybe you could be inspired by ticket #7857 and implement directly Henrici's algorithms.

Yann

comment:2 Changed 10 years ago by ylchapuy

  • Status changed from new to needs_review

I guess this should be closed as a duplicate of #9051

comment:3 Changed 10 years ago by robertwb

  • Milestone changed from sage-4.6 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from needs_review to closed
  • Type changed from defect to enhancement

Correct.

Note: See TracTickets for help on using tickets.