Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7882 closed defect (duplicate)

Macaulay2 interface breaks on examples

Reported by: novoselt Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Andrey Novoseltsev Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Present version of Macaulay2 interface breaks on

macaulay2("help matrix")

although

macaulay2.help("matrix")

does work fine.

The problem is that pexpect detects input prompts inside of examples. The patch changes the input prompt to get matches only in the beginning of lines.

The interface still breaks if you try to print input prompts at the beginning of the line, but that is probably a rare situation...

Attachments (1)

Macaulay2_prompt_only_in_the_beginning_of_lines.patch (1.2 KB) - added by novoselt 11 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by novoselt

  • Status changed from new to needs_review

comment:2 Changed 11 years ago by novoselt

  • Resolution set to duplicate
  • Status changed from needs_review to closed

Ticket #7897 fixes this in a better way.

comment:3 Changed 11 years ago by mvngu

  • Milestone set to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.