Opened 11 years ago

Closed 11 years ago

#7839 closed defect (duplicate)

Failure to coerce q^(-1) into its own LaurentPolynomialRing

Reported by: bump Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Consider:

sage: P.<q> = LaurentPolynomialRing(QQ)
sage: q in P
True
sage: P(q)
q
sage: q^(-1) in P
True
sage: P(q^(-1))

The last statement raises an exception.

Change History (2)

comment:1 Changed 11 years ago by nthiery

  • Cc sage-combinat added

comment:2 Changed 11 years ago by mhansen

  • Milestone changed from sage-4.3.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #3617 which should be fixed soon.

Note: See TracTickets for help on using tickets.