Opened 11 years ago

Closed 11 years ago

Last modified 6 years ago

#7816 closed defect (duplicate)

gd fails to build on Open Solaris - missing header file

Reported by: drkirkby Owned by: drkirkby
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Solaris Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

gd is not building on Open Solaris due to a missing header file X11/xpm.h.

gcc -DHAVE_CONFIG_H -I. -I. -I. -I/export/home/drkirkby/sage-4.3/local/include/freetype2 -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include -Wall -m64 -fPIC -g -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include/freetype2/ -MT gdkanji.lo -MD -MP -MF .deps/gdkanji.Tpo -c gdkanji.c -o gdkanji.o >/dev/null 2>&1
if /bin/sh ./libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.   -I/export/home/drkirkby/sage-4.3/local/include/freetype2 -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include   -Wall -m64 -fPIC -g -I"/export/home/drkirkby/sage-4.3/local/include" -I/export/home/drkirkby/sage-4.3/local/include/freetype2/ -MT gdtables.lo -MD -MP -MF ".deps/gdtables.Tpo" -c -o gdtables.lo gdtables.c; \
then mv -f ".deps/gdtables.Tpo" ".deps/gdtables.Plo"; else rm -f ".deps/gdtables.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I. -I. -I/export/home/drkirkby/sage-4.3/local/include/freetype2 -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include -Wall -m64 -fPIC -g -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include/freetype2/ -MT gdtables.lo -MD -MP -MF .deps/gdtables.Tpo -c gdtables.c  -fPIC -DPIC -o .libs/gdtables.o
 gcc -DHAVE_CONFIG_H -I. -I. -I. -I/export/home/drkirkby/sage-4.3/local/include/freetype2 -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include -Wall -m64 -fPIC -g -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include/freetype2/ -MT gdtables.lo -MD -MP -MF .deps/gdtables.Tpo -c gdtables.c -o gdtables.o >/dev/null 2>&1
if /bin/sh ./libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.   -I/export/home/drkirkby/sage-4.3/local/include/freetype2 -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include   -Wall -m64 -fPIC -g -I"/export/home/drkirkby/sage-4.3/local/include" -I/export/home/drkirkby/sage-4.3/local/include/freetype2/ -MT gdxpm.lo -MD -MP -MF ".deps/gdxpm.Tpo" -c -o gdxpm.lo gdxpm.c; \
then mv -f ".deps/gdxpm.Tpo" ".deps/gdxpm.Plo"; else rm -f ".deps/gdxpm.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I. -I. -I/export/home/drkirkby/sage-4.3/local/include/freetype2 -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include -Wall -m64 -fPIC -g -I/export/home/drkirkby/sage-4.3/local/include -I/export/home/drkirkby/sage-4.3/local/include/freetype2/ -MT gdxpm.lo -MD -MP -MF .deps/gdxpm.Tpo -c gdxpm.c  -fPIC -DPIC -o .libs/gdxpm.o
gdxpm.c:28:21: error: X11/xpm.h: No such file or directory
gdxpm.c: In function 'gdImageCreateFromXpm':
gdxpm.c:32: error: 'XpmInfo' undeclared (first use in this function)
gdxpm.c:32: error: (Each undeclared identifier is reported only once
gdxpm.c:32: error: for each function it appears in.)
gdxpm.c:32: error: expected ';' before 'info'
gdxpm.c:33: error: 'XpmImage' undeclared (first use in this function)
gdxpm.c:33: error: expected ';' before 'image'
gdxpm.c:42: warning: implicit declaration of function 'XpmReadFileToXpmImage'
gdxpm.c:42: error: 'image' undeclared (first use in this function)
gdxpm.c:42: error: 'info' undeclared (first use in this function)
gdxpm.c:43: error: 'XpmSuccess' undeclared (first use in this function)
make[4]: *** [gdxpm.lo] Error 1
make[4]: Leaving directory `/export/home/drkirkby/sage-4.3/spkg/build/gd-2.0.35.p2/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/export/home/drkirkby/sage-4.3/spkg/build/gd-2.0.35.p2/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/export/home/drkirkby/sage-4.3/spkg/build/gd-2.0.35.p2/src'
Error building gd.

Change History (3)

comment:1 Changed 11 years ago by drkirkby

  • Resolution set to duplicate
  • Status changed from new to closed

sorry, this is a duplicate of #7162

comment:2 Changed 11 years ago by mvngu

  • Milestone changed from sage-4.3.1 to sage-duplicate/invalid/wontfix

comment:3 Changed 6 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.