Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7762 closed defect (duplicate)

`conf.py` for Sage documentation hardcodes sagenb path

Reported by: timdumol Owned by: mvngu
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: documentation Keywords:
Cc: Merged in:
Authors: Tim Dumol Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

jhpalmieri on sage-devel:

As of 4.3.rc0, it looks like sagenb is perhaps being installed in the
wrong place, resulting in failures when building the documentation
with the "-j" option (it can't find some of the relevant javascript):

copying static files... WARNING: static directory '/Applications/sage/
local/lib/python/site-packages/sagenb/data/jsmath/' does not exist

In 4.3.alpha1, sagenb was installed in SAGE_ROOT/local/lib/python/site-
packages/.

In 4.3.rc0 and 4.3.rc1, sagenb is installed in SAGE_ROOT/local/lib/
python/site-packages/sagenb-0.4.7-py2.6.egg/

[...]

Attachments (1)

trac_7762-conf-sagenb-path.patch (2.2 KB) - added by timdumol 10 years ago.
Uses sagenb.misc.misc.DATA instead.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by timdumol

Uses sagenb.misc.misc.DATA instead.

comment:1 Changed 10 years ago by timdumol

  • Authors set to Tim Dumol
  • Cc was jhpalmieri added
  • Status changed from new to needs_review

comment:2 Changed 10 years ago by timdumol

  • Cc was jhpalmieri removed
  • Milestone changed from sage-4.3 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from needs_review to closed

comment:3 Changed 10 years ago by timdumol

This is a duplicate of #7755.

Note: See TracTickets for help on using tickets.