Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#7747 closed defect (fixed)

miscellaneous documentation fixes

Reported by: jhpalmieri Owned by: mvngu
Priority: blocker Milestone: sage-4.3
Component: documentation Keywords:
Cc: Merged in: sage-4.3.rc1
Authors: John Palmieri, Burcin Erocal Reviewers: Minh Van Nguyen
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jhpalmieri)

With Sage 4.3.rc0, I get a few doctest failures from sage/doc, at least one of which is related to #7406. The attached patch fixes them. It also reinstates some doctests which were disabled until #5338 was fixed.

Oh, and it also changes a .. math block to match the actual LaTeX output from Sage.

I'm marking this as a blocker since without it, there are doctest failures.

Attachments (1)

trac_7747-doc.patch (2.6 KB) - added by jhpalmieri 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by jhpalmieri

comment:1 Changed 12 years ago by jhpalmieri

  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 12 years ago by mvngu

  • Authors set to John Palmieri
  • Reviewers set to Minh Van Nguyen
  • Status changed from needs_review to positive_review

Doctesting Sage 4.3.rc0 on sage.math results in the following failures:

sage -t -long devel/sage/doc/en/constructions/calculus.rst
**********************************************************************
File "/scratch/mvngu/sandbox/sage-4.3.rc0-7747-doc/devel/sage-main/doc/en/constructions/calculus.rst", line 29:
    sage: latex(f.diff(x))
Expected:
    k x^{3} e^{k x} \sin\left(w x\right) + w x^{3} e^{k x} \cos\left(w x\right) + 3 \, x^{2} e^{k x} \sin\left(w x\right)
Got:
    k x^{3} e^{\left(k x\right)} \sin\left(w x\right) + w x^{3} e^{\left(k x\right)} \cos\left(w x\right) + 3 \, x^{2} e^{\left(k x\right)} \sin\left(w x\right)
**********************************************************************
1 items had failures:
   1 of   6 in __main__.example_0
***Test Failed*** 1 failures.
For whitespace errors, see the file /tmp/mvngu/tmp/.doctest_calculus.py
         [5.6 s]

sage -t -long devel/sage/doc/en/bordeaux_2008/nf_introduction.rst
**********************************************************************
File "/scratch/mvngu/sandbox/sage-4.3.rc0-7747-doc/devel/sage-main/doc/en/bordeaux_2008/nf_introduction.rst", line 300:
    sage: latex(a)
Expected:
    -\frac{1}{2} \, {(I \, \sqrt{3} + 1)} ...
Got:
    -\frac{1}{2} \, {\left(I \, \sqrt{3} + 1\right)} {\left(\frac{1}{18} \, \sqrt{8 \, \sqrt{2} + 675} \sqrt{3} - \frac{5}{2}\right)}^{\left(\frac{1}{3}\right)} + \frac{1}{6} \, \frac{{\left(-I \, \sqrt{3} + 1\right)} \sqrt{2}\
}{{\left(\frac{1}{18} \, \sqrt{8 \, \sqrt{2} + 675} \sqrt{3} - \frac{5}{2}\right)}^{\left(\frac{1}{3}\right)}}
**********************************************************************
1 items had failures:
   1 of   7 in __main__.example_10
***Test Failed*** 1 failures.
For whitespace errors, see the file /tmp/mvngu/tmp/.doctest_nf_introduction.py
         [3.6 s]

The patch trac_7747-doc.patch fixes both of these failures. All doctests now pass on sage.math.

comment:3 Changed 12 years ago by jhpalmieri

This is a duplicate of #7659, but the patch here does a little more. Can we use this patch instead of that one?

comment:4 Changed 12 years ago by mhansen

  • Merged in set to sage-4.3.rc1
  • Resolution set to fixed
  • Status changed from positive_review to closed

I've merged the patch here instead of the one at #7659.

comment:5 Changed 12 years ago by jhpalmieri

Could you please make sure that burcin also gets author credit for this (for his work on #7659)? Thanks.

comment:6 Changed 12 years ago by mhansen

  • Authors changed from John Palmieri to John Palmieri, Burcin Erocal

Done.

Note: See TracTickets for help on using tickets.