Opened 8 years ago

Closed 8 years ago

#7718 closed defect (fixed)

Segfault in coercion code

Reported by: roed Owned by: robertwb
Priority: critical Milestone: sage-4.3
Component: coercion Keywords: coercion, segfault
Cc: Merged in: sage-4.3.rc1
Authors: David Roe Reviewers: Robert Bradshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

A segfault is caused by failure to check whether elements are None.

Attachments (1)

7718.patch (1.3 KB) - added by roed 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by roed

comment:1 Changed 8 years ago by roed

  • Status changed from new to needs_review

comment:2 Changed 8 years ago by robertwb

  • Status changed from needs_review to positive_review

Nice catch.

comment:3 Changed 8 years ago by mhansen

  • Authors changed from roed to David Roe
  • Merged in set to sage-4.3.rc1
  • Resolution set to fixed
  • Reviewers set to Robert Bradshaw
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.