Opened 11 years ago

Closed 11 years ago

#7717 closed enhancement (duplicate)

sage -coverage enhancement

Reported by: roed Owned by: mvngu
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: documentation Keywords: coverage
Cc: Merged in:
Authors: roed Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Adds features to the sage-coverage script.

  • rewrite for modularity and easier addition of features
  • changes the score of the file to reflect the presence or absence of a TestSuite?.run or equivalent test.
  • adds option to check cdef'd functions
  • adds option to check docstrings on classes
  • adds option to check for the existence of INPUT block
  • adds option to check that parameters are all listed in the INPUT block.
  • adds option to check for the existence of OUTPUT block

So that we don't bring our coverage level way down, these aren't turned on automatically. Instead, they can be invoked from the command line by using options ( -cdefs, -classes, -input, -output and -params)

Change History (2)

comment:1 Changed 11 years ago by roed

Duplicate of 7716: please delete.

comment:2 Changed 11 years ago by mvngu

  • Milestone changed from sage-4.3 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as a duplicate of #7716.

Note: See TracTickets for help on using tickets.