Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#7702 closed defect (duplicate)

Handle interrupts better in the notebook

Reported by: boothby Owned by: was
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Interrupting the notebook is less robust than it used to be. The attached worksheet is an example where the notebook fails to interrupt. When this happens, the notebook acts as though it's interrupted.

Attachments (1)

interrupt test.sws (1.3 KB) - added by boothby 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by boothby

comment:1 Changed 9 years ago by was

I have verified this. It is a *very* bad bug, since it means that one thinks the notebook got interrupted, but it didn't. This results in a seemingly totally broken worksheet, which must cause massive confusion to everybody, to say the least.

comment:2 Changed 9 years ago by was

(Oh, and it is surely my fault since I rewrote the interrupt code in the notebook separation.)

comment:3 Changed 9 years ago by timdumol

The patch at #5712 should fix the problem.

comment:4 Changed 8 years ago by jdemeyer

Hard to say what's going on here. My guess would be a bare except: somewhere catching the KeyboardInterrupt.

comment:5 Changed 8 years ago by jdemeyer

  • Milestone set to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

I cannot reproduce the problem anymore in recent versions of Sage, so I assume it got fixed by #9678.

comment:6 Changed 8 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Work issues interrupt notebook deleted
Note: See TracTickets for help on using tickets.