Opened 11 years ago

Closed 10 years ago

#7701 closed enhancement (duplicate)

update the openmpi spkg to the latest version

Reported by: was Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: jdemeyer Merged in:
Authors: Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description


Change History (7)

comment:1 Changed 11 years ago by was

Spkg in progress here:

http://sage.math.washington.edu/home/wstein/patches/openmpi-1.4.spkg

This doesn't work, and fails with this error:

/bin/bash ./libtool --tag=CC   --mode=link gcc  -O3 -DNDEBUG   -fvisibility=hidden -module -avoid-version  -o dlopen.la  dlopen.lo -ldl -ldl -lnsl -lutil  -lm
libtool: link: ar cru .libs/dlopen.a .libs/dlopen.o
libtool: link: ranlib .libs/dlopen.a
rm: cannot remove `dlopen.la': No such file or directory
libtool: link: ( cd ".libs" && rm "dlopen.la" && ln -s "../dlopen.la" "dlopen.la" )
rm: cannot remove `dlopen.la': No such file or directory
make[3]: *** [dlopen.la] Error 1
make[3]: Leaving directory `/scratch/wstein/build/sage-4.3.rc0/spkg/build/openmpi-1.4/src/opal/libltdl'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/scratch/wstein/build/sage-4.3.rc0/spkg/build/openmpi-1.4/src/opal/libltdl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/scratch/wstein/build/sage-4.3.rc0/spkg/build/openmpi-1.4/src/opal'
make: *** [all-recursive] Error 1
Error building

comment:2 Changed 11 years ago by vbraun

The reason for this error is that newer versions of libtool break when you define $RM="rm", see http://trac.sagemath.org/sage_trac/ticket/7818#comment:28

Temporary work-around is adding unset RM to spkg-install

comment:3 Changed 10 years ago by thisch

this ticket should be fixed according to the release notes of sage 4.6.2, right ?

#8537: Stefan Reiterer: Update Open MPI package to latest - Sage version is 3 years old! [Reviewed by Volker Braun]

comment:4 follow-up: Changed 10 years ago by vbraun

  • Cc jdemeyer added

Sage-4.6.2 has openmpi-1.4.3 as optional spkg.

Release manager: Please close this ticket.

comment:5 Changed 10 years ago by thisch

any reason why this ticket is still open?

comment:6 in reply to: ↑ 4 Changed 10 years ago by jdemeyer

  • Milestone changed from sage-4.7.1 to sage-duplicate/invalid/wontfix
  • Reviewers set to Volker Braun
  • Status changed from new to needs_review

Replying to vbraun:

Sage-4.6.2 has openmpi-1.4.3 as optional spkg.

Release manager: Please close this ticket.

comment:7 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.