Opened 12 years ago

Last modified 7 years ago

#7559 needs_work enhancement

replace all the deprecation warning using deprecated_function_alias whenever possible

Reported by: hivert Owned by: tbd
Priority: trivial Milestone: sage-6.4
Component: misc Keywords:
Cc: ncohen, hivert Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This was suggested by Nathann Cohen. This is a followup of #7515 where a short mantra for deprecated function aliases is set-up.

I'll not have the time to do this right now so any volunteer is welcome.

Cheers

Florent

Change History (8)

comment:1 Changed 9 years ago by vbraun

  • Status changed from new to needs_review

This ticket isn't really a precise task. I think with #13109 any non-optimal use of deprecation should just die out eventually.

I propose we close this ticket as invalid.

comment:2 Changed 9 years ago by kcrisman

  • Priority changed from major to minor
  • Status changed from needs_review to needs_work
  • Type changed from defect to enhancement

I don't know about this being imprecise. It says to replace deprecation with deprecation_function_alias wherever possible. It's true that they will be removed someday, so this isn't a very high priority ticket! But given that many of them haven't been removed yet, if someone really wanted to, this would be an ok thing to do by someone wanting to learn how to develop for Sage.

I'm downgrading and turning this into an enhancement, since this is not really a bug at all. Once older deprecations are removed one could also closed this ticket.

comment:3 follow-up: Changed 9 years ago by vbraun

Any volunteers for beautifying the deprecations so that they'll look really good when we delete them next year? No? Thought so!

comment:4 in reply to: ↑ 3 Changed 9 years ago by kcrisman

  • Priority changed from minor to trivial

Any volunteers for beautifying the deprecations so that they'll look really good when we delete them next year? No? Thought so!

Obviously. However, there haven't even been any volunteers for deleting some of the deprecations in question - some of which are nearly three years old! Just because a ticket is fairly pointless doesn't mean it isn't valid, if you take my meaning :) Downgrading to trivial.

comment:5 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:6 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:7 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:8 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4
Note: See TracTickets for help on using tickets.