Opened 13 years ago

Closed 12 years ago

#7524 closed defect (fixed)

frame axes are lost when saving a graphic to a file

Reported by: Jason Grout Owned by: William Stein
Priority: major Milestone: sage-4.6.2
Component: graphics Keywords:
Cc: Andrey Novoseltsev, Jason Grout Merged in: sage-4.6.2.alpha3
Authors: Karl-Dieter Crisman Reviewers: Andrey Novoseltsev
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Notice that the frame axes are shown when using "show", but are missing when using "save"

----------------------------------------------------------------------
| Sage Version 4.2.1, Release Date: 2009-11-14                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
sage: var('x,y')                
(x, y)
sage: a=plot_vector_field((x,-y),(x,-1,1),(y,-1,1))
sage: a.show()
sage: a.save('test.png')

Attachments (1)

trac_7524-options-save.patch (1.0 KB) - added by Karl-Dieter Crisman 12 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by Jason Grout

Status: newneeds_review

This is fixed with #7981

comment:2 Changed 13 years ago by Ross Kyprianou

Status: needs_reviewneeds_work

Got the following on applying trac-7981-show_options.patch to sage-4.3.2-alpha

~/sage-4.3.2.alpha0/devel/sage-main$ hg qpush applying trac-7981-show_options.patch patching file sage/plot/plot.py Hunk #3 FAILED at 1913 1 out of 5 hunks FAILED -- saving rejects to file sage/plot/plot.py.rej patch failed, unable to continue (try -v) patch failed, rejects left in working dir errors during apply, please fix and refresh trac-7981-show_options.patch

comment:3 Changed 12 years ago by Karl-Dieter Crisman

Work issues: check works, document with patch

Might be worth trying this again, now that #7981 has positive review. Would need a patch to document.

comment:4 Changed 12 years ago by Karl-Dieter Crisman

I can confirm that this works after #7981.

comment:5 Changed 12 years ago by Karl-Dieter Crisman

Work issues: check works, document with patch

This test checks that it works. Passes relevant test, plot looks good.

Changed 12 years ago by Karl-Dieter Crisman

comment:6 Changed 12 years ago by Karl-Dieter Crisman

Authors: Karl-Dieter Crisman
Cc: Andrey Novoseltsev Jason Grout added
Status: needs_workneeds_review

This definitely depends on #7981, #8632, and #10244. It's conceivable, but unlikely, that it depends on #10143, and might also depend on #2100. All in that order. This is because it applies to the very popular file plot.py.

comment:7 Changed 12 years ago by Andrey Novoseltsev

Reviewers: Andrey Novoseltsev
Status: needs_reviewpositive_review

Let's say it depends on #10143, since it has positive review already. The patch looks and applies fine, positive review!

comment:8 Changed 12 years ago by Karl-Dieter Crisman

I've set #2100 to 'needs work', but this still applies fine after #7981, #8632, #10244, and #10143 on 4.6.2.alpha1, so still should be included in the next alpha.

comment:9 Changed 12 years ago by Jeroen Demeyer

Merged in: sage-4.6.2.alpha3
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.