Opened 11 years ago

Closed 10 years ago

#7513 closed task (fixed)

Update Mercurial to 1.6.4

Reported by: mhansen Owned by: leif
Priority: major Milestone: sage-4.6.1
Component: packages: standard Keywords: hg spkg
Cc: leif, jdemeyer Merged in: sage-4.6.1.alpha1
Authors: Jeroen Demeyer, Leif Leonhardy Reviewers: Leif Leonhardy, Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

Upstream: http://mercurial.selenic.com/

The current version is 1.6.4, the version shipped with Sage 4.6 is 1.3.1.

Cool new functionality: hg qpush --move allows to push a patch out of order, i.e. it can be used to reorder patches.

New spkg: http://sage.math.washington.edu/home/jdemeyer/spkg/mercurial-1.6.4.p0.spkg

Attachments (2)

trac_7513-clean_up_spkg-install_SPKG.txt-reviewer.patch (5.3 KB) - added by leif 10 years ago.
SPKG reviewer patch, based on Jeroen's changes.
7513_review_review.patch (2.3 KB) - added by jdemeyer 10 years ago.
Apply on top of leif's patch

Download all attachments as: .zip

Change History (20)

comment:1 Changed 11 years ago by leif

  • Cc leif added
  • Milestone changed from sage-4.5.3 to sage-4.6
  • Report Upstream set to N/A

comment:2 Changed 11 years ago by leif

  • Description modified (diff)
  • Keywords hg spkg added
  • Summary changed from Update Mercurial to 1.4 to Update Mercurial to 1.6

comment:3 Changed 10 years ago by jdemeyer

  • Cc jdemeyer added

comment:4 Changed 10 years ago by jdemeyer

  • Description modified (diff)

comment:5 Changed 10 years ago by jdemeyer

  • Description modified (diff)
  • Status changed from new to needs_review
  • Summary changed from Update Mercurial to 1.6 to Update Mercurial to 1.6.4

Changed 10 years ago by leif

SPKG reviewer patch, based on Jeroen's changes.

comment:6 follow-up: Changed 10 years ago by leif

  • Authors set to Jeroen Demeyer
  • Reviewers set to Leif Leonhardy

I originally wanted to give it immediately a positive review, though patches/posix.py.patch (which is redundant and for reference only) had not been updated, but just the line numbers changed. (I haven't updated it either.)

Jeroen's changes look fine, except spkg-install still tried to copy an obsolete, now removed patch (to setup.py).

Then I took a closer look at the rest (including SPKG.txt), which ended up in my reviewer patch.

Jeroen, if you agree with my changes, please merge them into the spkg, and I can give it positive review. ;-)

comment:7 in reply to: ↑ 6 ; follow-up: Changed 10 years ago by jdemeyer

Replying to leif:

I originally wanted to give it immediately a positive review, though patches/posix.py.patch (which is redundant and for reference only) had not been updated, but just the line numbers changed. (I haven't updated it either.)

Since the patch still applies perfectly fine, I don't think it is a problem that the line numbers don't match (note that I created patches/posix.py from patches/posix.py.patch, not the other way around).

Jeroen's changes look fine, except spkg-install still tried to copy an obsolete, now removed patch (to setup.py).

Thanks for spotting this.

Then I took a closer look at the rest (including SPKG.txt), which ended up in my reviewer patch.

Jeroen, if you agree with my changes, please merge them into the spkg, and I can give it positive review. ;-)

Thanks for looking more carefully at this, I just wanted a new spkg quickly :-)

comment:8 Changed 10 years ago by jdemeyer

  • Authors changed from Jeroen Demeyer to Jeroen Demeyer, Leif Leonhardy
  • Reviewers changed from Leif Leonhardy to Leif Leonhardy, Jeroen Demeyer

Leif, I added some minor changes (7513_review_review.patch) and posted the resulting spkg at http://sage.math.washington.edu/home/jdemeyer/spkg/mercurial-1.6.4.p0.spkg. Please review.

Changed 10 years ago by jdemeyer

Apply on top of leif's patch

comment:9 in reply to: ↑ 7 Changed 10 years ago by leif

Replying to jdemeyer:

Since the patch still applies perfectly fine, I don't think it is a problem that the line numbers don't match (note that I created patches/posix.py from patches/posix.py.patch, not the other way around).

Obviously. Florent recently complained about a patch of mine that wasn't based on vanilla and so (just) the line numbers changed s.t. Mercurial operated more verbosely than usual. ;-)

In general it's better to also touch the diffs, or keep them in full sync with the patched files; I've come across spkgs where apparently obsolete files were copied over; and it's confusing when there are dead old patches that do not reflect the current differences.

Thanks for looking more carefully at this, I just wanted a new spkg quickly :-)

Well, the ticket's first (opening) anniversary is close...

comment:10 Changed 10 years ago by leif

Yes, I forgot to suggest you removing the code commented out.

Reviewed reviewer's patch looks ok.

I wasn't sure if quoting the '$' was intended or not, but assumed the latter. Giving the effective filename would IMHO be ok, too.

Going to check the new spkg...

comment:11 Changed 10 years ago by leif

  • Owner changed from tbd to leif

Ooops, did you patch/upload the wrong package?

I have a completely different upstream src now... (and the size decreased significantly)

comment:12 Changed 10 years ago by leif

Yep, it's the old one again:

Finished installing mercurial-1.6.4.p0.spkg

real    0m2.384s
user    0m1.960s
sys     0m0.430s
leif@quadriga:~/Sage/sage-4.6$ ./sage -hg --version
Mercurial Distributed SCM (version 1.3.1)

Copyright (C) 2005-2009 Matt Mackall <mpm@selenic.com> and others
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

comment:13 Changed 10 years ago by jdemeyer

Replying to leif:

Ooops, did you patch/upload the wrong package?

I have a completely different upstream src now... (and the size decreased significantly)

You are totally right, I forgot to update the src/ directory when making the new spkg. I automated this for the PARI spkg and forgot that not every spkg does this automatically :-)

comment:14 Changed 10 years ago by jdemeyer

Should be fixed now, sorry for this...

comment:15 Changed 10 years ago by leif

! patches/setup.py
! patches/setup.py.patch

;-)

comment:16 Changed 10 years ago by jdemeyer

Next attempt...

comment:17 Changed 10 years ago by leif

  • Status changed from needs_review to positive_review

comment:18 Changed 10 years ago by jdemeyer

  • Merged in set to sage-4.6.1.alpha1
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.