Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#7455 closed defect (fixed)

SageNB - Searching on Log page does not work

Reported by: timdumol Owned by: boothby
Priority: major Milestone: sage-4.3
Component: notebook Keywords:
Cc: Merged in: sagenb-0.4.6
Authors: Tim Dumol Reviewers: William Stein
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Searching for anything on the Log page does not work due to missing javascript libraries.

Attachments (1)

trac_7455-searching-on-log-page.patch (2.6 KB) - added by timdumol 13 years ago.
This remvoes the search bar from the history page and updates the tests to reflect that.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by AlexGhitza

  • Component changed from algebra to notebook
  • Milestone set to sage-4.3
  • Owner changed from AlexGhitza to boothby

Changed 13 years ago by timdumol

This remvoes the search bar from the history page and updates the tests to reflect that.

comment:2 Changed 13 years ago by timdumol

The problem is apparently a bit harder to fix. It requires a few changes to the js libraries. For now, this patch is a temporary fix.

comment:3 Changed 13 years ago by timdumol

  • Status changed from new to needs_review

I have thought over this, and it seems to me that it makes more sense to keep the search box only in the worksheet list pages (Home and Published). If there are no objections, then the previous patch removing the search box should be the one included.

comment:4 Changed 13 years ago by was

  • Report Upstream set to N/A
  • Status changed from needs_review to positive_review

I agree with this patch. It would of course be better to just get rid of the whole top bar, and make all the cells be properly styled, etc. But this current patch is very simple at and at least fixes this bug. Positive review.

comment:5 Changed 13 years ago by was

  • Resolution set to fixed
  • Status changed from positive_review to closed

merged in sagenb-0.4.6

comment:6 Changed 13 years ago by mvngu

  • Summary changed from SageNB - Searching on Log page does not work. to SageNB - Searching on Log page does not work

comment:7 Changed 13 years ago by mvngu

  • Authors set to Tim Dumol
  • Merged in set to sagenb-0.4.6
  • Reviewers set to William Stein
Note: See TracTickets for help on using tickets.