Opened 11 years ago

Closed 6 years ago

Last modified 6 years ago

#7422 closed enhancement (duplicate)

New Incidence Structure and Block Design constructions

Reported by: brett Owned by: brett
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords: Block Design, Incidence Structure, Residual, Derived, Complement, Supplement, Point Deletion
Cc: rbeezer, wdj Merged in:
Authors: Brett Stevens Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I have added two references; fixed the points() method to return points in lexicographic order so eq works properly; made is_simple() its own standalone method and call it from block_design_checker and added the following constructions: Derived at a Point, Residual at a Point, Derived at a Block, Residual at a Block, Complementary, Supplementary, Point Deletion and Extraction of Blocks by size.

Some relevant discussion is here:

http://groups.google.com/group/sage-devel/browse_thread/thread/305158ab5d3181bc

Reviewers:

  • Please think about my first item on the TODO list; is that a better way to proceed with derived_blck and residual_blck?

-I do not know whether this is "Minor" or "Major" (I am pretty sure it is not the others) so I have put "Major". Please tell me if I was wrong.

  • I have no idea what to put in Milestone so I have left it blank.

Attachments (1)

trac_7422_block_design_constructions.patch (16.1 KB) - added by brett 11 years ago.
Patch with new constructions

Download all attachments as: .zip

Change History (15)

comment:1 Changed 11 years ago by brett

  • Cc rbeezer wdj added; beezer@… removed
  • Status changed from new to needs_review

comment:2 follow-up: Changed 11 years ago by jason

Just a python and Sage style note: unless there is a huge significant reason, things in function names should be spelled out. So, for example, residual_pt should be residual_point, blck should be "block", etc. This makes a huge difference in readability for someone that is using the module, reading code written by others, etc.

comment:3 in reply to: ↑ 2 Changed 11 years ago by brett

Replying to jason:

Just a python and Sage style note: unless there is a huge significant reason, things in function names should be spelled out. So, for example, residual_pt should be residual_point, blck should be "block", etc. This makes a huge difference in readability for someone that is using the module, reading code written by others, etc.

OK, I will make this change, thanks.

Changed 11 years ago by brett

Patch with new constructions

comment:4 Changed 11 years ago by brett

I have changed the function names so they are all fully descriptive of what they do.

I also have a question. When I run:

sage -coverage Projects/SAGE/sage-source/devel/sage/sage/combinat/designs/incidence_structures.py

I do get 100% coverage but I also get:

ERROR: Please add a TestSuite(s).run() doctest.

I have looked in the sage reference manual and the developers guide to see what this is and how I add such a thing, but to no avail. If someone knows what this is please tell me or send a link to a page that describes it. When I know what to do, I will add one of these.

comment:5 Changed 11 years ago by jason

Here is the patch for adding such a thing to matrices in Sage. You might find the code useful as an example.

#6936

Here is the ticket that introduced the framework:

#6343

I don't know where this is documented, but there probably is a mailing list message or two about it.

comment:6 Changed 11 years ago by drkirkby

  • Owner changed from mhansen to (none)
  • Report Upstream set to N/A

Has this been checked on Solaris?

There's general information about building on Solaris at

http://wiki.sagemath.org/solaris

Information specifically for 't2' at

http://wiki.sagemath.org/devel/Building-Sage-on-the-T5240-t2

Both the source (4.3.0.1 is the latest to build on Solaris) and a binary which will run on any SPARC can be found at http://www.sagemath.org/download-source.html

Dave

comment:7 Changed 11 years ago by ncohen

  • Status changed from needs_review to needs_work

I do not know if this patch is still necessary, but if it is it needs to be rebased.

12 out of 12 hunks FAILED -- saving rejects to file sage/combinat/designs/incidence_structures.py.rej

Nathann

comment:8 Changed 6 years ago by brett

  • Owner changed from (none) to brett

comment:9 Changed 6 years ago by ncohen

@brett: here is [1] the procedure to follow if you want to close this ticket. Note that while the doc says that you should switch it to 'needs review'first, we usually directly change the status to 'positive review' in this specific case.

Nathann

[1] http://www.sagemath.org/doc/developer/trac.html#reviewing-and-closing-tickets

comment:10 Changed 6 years ago by brett

This ticket should be closed. It has been superseded by ticket #16534

Last edited 6 years ago by brett (previous) (diff)

comment:11 Changed 6 years ago by brett

  • Status changed from needs_work to positive_review

comment:12 Changed 6 years ago by vbraun

you should also set the milestone to duplicate...

comment:13 Changed 6 years ago by vbraun

  • Milestone set to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:14 Changed 6 years ago by brett

thanks

Note: See TracTickets for help on using tickets.