Opened 11 years ago

Closed 11 years ago

#7394 closed defect (duplicate)

sqrt(e) causes segfaults

Reported by: edrex Owned by: burcin
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: jason Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

multiplying/dividing sqrt(e) with anything other than 1 causes a segfault, for example:

2*sqrt(e)

tested with source compile i686 and sagenb.org

Change History (4)

comment:1 Changed 11 years ago by jason

  • Cc jason added

comment:2 Changed 11 years ago by mhansen

Pynac gets into an infinite recursion with these lines:

#141 0x00007ff794d21de6 in GiNaC::ex::construct_from_basic (other=@0x7fff450abfe6) at ex.cpp:312
#142 0x00007ff794dc7405 in GiNaC::mul::eval (this=0x57772f0, level=<value optimized out>) at ex.h:267

comment:3 Changed 11 years ago by AlexGhitza

  • Component changed from algebra to symbolics
  • Owner changed from AlexGhitza to burcin

comment:4 Changed 11 years ago by burcin

  • Milestone changed from sage-4.3 to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #7264. The patch attached to that ticket contains this example as a doctest as well.

Note: See TracTickets for help on using tickets.