Opened 11 years ago

Closed 11 years ago

#7372 closed defect (duplicate)

Fix iterator for finite fields

Reported by: rbeezer Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords: finite field iterator
Cc: malb, ylchapuy Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: K.<a>=GF(2^16)
sage: K.list()
...
TypeError: 'sage.rings.ring.FiniteFieldIterator' object is not iterable

See #7366 for smaller fields (givaro implementation), this is for fields as large as 216.

Discussion: http://groups.google.com/group/sage-devel/browse_thread/thread/f141bdaaebf4bcbf

Attachments (1)

trac_7372_finite_field_iteration.patch (982 bytes) - added by rbeezer 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by rbeezer

comment:1 Changed 11 years ago by malb

This is a dupe of #7370 although your doctest is better :)

comment:2 Changed 11 years ago by rbeezer

OK, malb caught me in the act, and this is fixed. See #7370.

Release manager - mark this obsolete.

comment:3 Changed 11 years ago by mhansen

  • Milestone changed from sage-4.2.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.