Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7352 closed defect (fixed)

Update prereq to version 0.5

Reported by: drkirkby Owned by: tbd
Priority: major Milestone: sage-4.3
Component: build Keywords:
Cc: Merged in: sage-4.3.alpha0
Authors: David Kirkby Reviewers: Mike Hansen
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by drkirkby)

Following my recent updates of the code for checking the prerequisites for Sage are present (#7021), here is a further refinement. If implemented the following tickets can be closed.

  • #7156 prereq-0.4 has a minor portability issue.
  • #7142 We must check if the version of 'tar' found is gnu tar
  • #7143 We must check if the version of 'make' found is gnu 'make'
  • #7181 We must ensure we have GNU make, not HP-UX or Solaris 'make'
  • #7203 prereq-0.4 does not exit if CC is not gcc, but CXX is g++
  • #7182 HP-UX failure of gfan-0.3.p4 but easier to ensure we have GNU make.

Changes are:

Changes to configure.ac

  • Insists that the configure script is created using autoconf 2.63 or later.
  • Checks for latex and issues a gentle warning if it's not found, but makes it clear that latex is not essential.
  • Exits if gcc is not used as the C compiler, but g++ is used as the C++ compiler. (In prereq-0.4 an error message was generated if gcc was used as the C compiler, but g++ was not used as the C++ compiler). This addresses the other mixture, which I'd overlooked before.
  • Issues a warning that Solaris is unsupported on versions 9 or older.
    • If sun4c or sun4m hardware is used, the configure script reports it is not possible to update to Solaris 10, and so problems might exist.
    • If other Sun hardware is used, it advises people to update unless they have reasons for needing an old release of Solaris.
  • Issues a warning that Darwin is too old on 5.x, 5.x.y, 6.x, 6.x.y, 7.x and 7.x.y. It states the oldest version of OS X on which Sage has been built is 10.4 (Tiger). The information about the relationship between Darwin and OS X versions is taken from http://en.wikipedia.org/wiki/Darwin_(operating_system)
  • Exits if bash can not be found.
    • Suggests bash might be found in /opt/OpenSource/bin/ if the operating system is HP-UX.
    • Suggests bash might be found in /opt/pware/bin if the operating system is AIX.
  • Checks for ar, strip, m4, ranlib and ld.

Changes to prereq-0.5-install

  • Checks for GNU tar and GNU make on Solaris, making suggestions where they might be found (/usr/sfw/bin) or obtained via source, Blastwave or Sunfreeware.
  • Only uses the -p option to uname on Solaris. Previously the option was used on all platforms to check for Solaris on SPARC or x86. Since this option is not portable (not part of POSIX), it generated an error on HP-UX.
  • Removed all the checks for programs like gcc, ld since these were not portable, and always indicated the program was present on Solaris, even if it was not.

The code may be found here.

http://sage.math.washington.edu/home/kirkby/Solaris-fixes/prereq-0.5-3rd-try/

Note both files need to be downloaded to $SAGE_ROOT/spkg/base, and the permissions on the script need to be 755. When it is downloaded via the web, the execute permissions will be lost.

Change History (9)

comment:1 Changed 11 years ago by drkirkby

  • Description modified (diff)

comment:2 Changed 11 years ago by drkirkby

  • Status changed from new to needs_review

comment:3 Changed 11 years ago by drkirkby

  • Description modified (diff)

comment:4 Changed 11 years ago by drkirkby

  • Summary changed from Update prereq to version 0.5 to [needs review] Update prereq to version 0.5

comment:5 Changed 11 years ago by drkirkby

  • Description modified (diff)

comment:6 Changed 11 years ago by drkirkby

  • Description modified (diff)

comment:7 Changed 11 years ago by drkirkby

  • Description modified (diff)

comment:8 Changed 11 years ago by mhansen

  • Merged in set to sage-4.3.alpha0
  • Resolution set to fixed
  • Reviewers set to Mike Hansen
  • Status changed from needs_review to closed

Looks good to me.

comment:9 Changed 11 years ago by mvngu

  • Report Upstream set to N/A
  • Summary changed from [needs review] Update prereq to version 0.5 to Update prereq to version 0.5
Note: See TracTickets for help on using tickets.