Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7327 closed defect (fixed)

Make integrate accept a variable range as a tuple

Reported by: jason Owned by: burcin
Priority: major Milestone: sage-4.2.1
Component: calculus Keywords:
Cc: kcrisman Merged in: sage-4.2.1.alpha0
Authors: Jason Grout, Karl-Dieter Crisman Reviewers: Karl-Dieter Crisman, Jason Grout, Mike Hansen
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

It is inconsistent with plot and other functions that this just hangs:

integrate(sin(x), (x,0,1))

This patch takes care of this.

Attachments (2)

trac-7327-integrate-range.patch (2.9 KB) - added by jason 10 years ago.
trac_7327-updated.patch (4.6 KB) - added by kcrisman 10 years ago.
Based on Sage 4.2

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by jason

comment:1 Changed 10 years ago by kcrisman

  • Status changed from new to needs_work

This is a duplicate of #6816. The tests for one of these should be incorporated in the other - probably in this one, since it has some doc upgrades - and probably also the check for too many arguments in the tuple.

Changed 10 years ago by kcrisman

Based on Sage 4.2

comment:2 Changed 10 years ago by kcrisman

  • Authors changed from Jason Grout to Jason Grout, Karl-Dieter Crisman
  • Reviewers set to Karl-Dieter Crisman, Jason Grout
  • Status changed from needs_work to needs_review

Updated patch includes the issues mentioned in previous comment, is ready for review. Positive review to the parts I didn't write.

comment:3 Changed 10 years ago by mhansen

  • Reviewers changed from Karl-Dieter Crisman, Jason Grout to Karl-Dieter Crisman, Jason Grout, Mike Hansen
  • Status changed from needs_review to positive_review

Looks good to me.

comment:4 Changed 10 years ago by mhansen

  • Merged in set to sage-4.2.1.alpha0
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:5 Changed 10 years ago by kcrisman

  • Report Upstream set to N/A

Just an update - it turns out the original integral reported in #6816 is not, in fact, convergent. Fixing this doctest so something mathematically correct happens will be done in #7745, since Maxima 5.20.1 simply returns that integral now, as opposed to giving 0.

Note: See TracTickets for help on using tickets.