Opened 12 years ago

Closed 12 years ago

#7316 closed defect (fixed)

notebook: default values for variables are printed incorrectly in docstrings

Reported by: jhpalmieri Owned by: boothby
Priority: major Milestone: sage-4.2.1
Component: notebook Keywords:
Cc: was Merged in:
Authors: John Palmieri Reviewers: Mitesh Patel, Tim Dumol
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

From sage-notebook:

> I notice that in Sage 4.2, the version of sageinspect in the notebook 
> doesn't match the one in sage.misc -- the one in sagenb/misc is 
> missing the fix from Trac #6848.  As a result, 
> {{{ 
> RDF.random_element? 
> }}} 
> produces incorrect output, as noted on the ticket.  Should this be 
> fixed, or was the fix intentionally omitted because it uses "eval"? 

For the fix, see the patch at #6848, especially the new lines 269-270 (and the associated doctest fixes).

Attachments (1)

trac_7316-sageinspect_defn.patch (8.5 KB) - added by mpatel 12 years ago.
Fix Cython docstring "Definition". Rebase of sageinspect part of #6848. Apply to sagenb repository.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by mpatel

Fix Cython docstring "Definition". Rebase of sageinspect part of #6848. Apply to sagenb repository.

comment:1 Changed 12 years ago by mpatel

  • Authors set to John Palmieri
  • Status changed from new to needs_review

All doctests pass, if I copy the patched sagenb.misc.sageinspect.py to $SAGE_ROOT/devel/sage/sage, say, and run sage -t sageinspect.py in that directory.

To the extent that it counts, my review is positive.

comment:2 Changed 12 years ago by jhpalmieri

Is this now a duplicate of #7349?

comment:3 Changed 12 years ago by timdumol

  • Cc was added
  • Reviewers set to Mitesh Patel, Tim Dumol
  • Status changed from needs_review to positive_review

Doctests count and the the bugs are fixed. Positive review.

comment:4 Changed 12 years ago by was

  • Milestone changed from sage-4.3 to sage-4.2.1
  • Resolution set to fixed
  • Status changed from positive_review to closed

merged into sagenb-0.4.2 (sage-4.2.1)

Note: See TracTickets for help on using tickets.