Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7256 closed defect (duplicate)

reset() needs to be improved

Reported by: mhampton Owned by: wstein
Priority: major Milestone:
Component: notebook Keywords: reset, notebook, sage-4.1.2
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In sage-4.1.2, reset() causes problems by deleting 'sagenb' from the namespace; there may be other important things deleted as well.

A simple fix might be to add 'sagenb' to the sage.misc.reset.EXCLUDE list. But perhaps a more extensive rewrite of this function would be better.

Change History (2)

comment:1 Changed 11 years ago by mhampton

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 11 years ago by mhampton

This is a duplicate of #7255, sorry about that.

Note: See TracTickets for help on using tickets.