Opened 10 years ago

Closed 10 years ago

#7248 closed enhancement (duplicate)

include jinja2 / upgrade jinja spkg

Reported by: ddrake Owned by: boothby
Priority: major Milestone: sage-4.2
Component: notebook Keywords:
Cc: jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I'm not sure whether this is an upgrade or a new spkg, but the plan is to switch the notebook to Jinja2, which will require updating/replacing the current Jinja spkg.

John Palmieri has a proposed spkg at #6586.

Change History (5)

comment:1 in reply to: ↑ description ; follow-up: Changed 10 years ago by jhpalmieri

John Palmieri has a proposed spkg at #6586.

"Proposed"? It's in Sage 4.2.alpha0.

Some work needs to be done if you want to get rid of Jinja -- last time I checked, some parts of the Sage library use things from Jinja that it wasn't immediately obvious how to replace using Jinja2: see this comment from #6586.

comment:2 in reply to: ↑ 1 Changed 10 years ago by ddrake

  • Resolution set to fixed
  • Status changed from new to closed

Replying to jhpalmieri:

John Palmieri has a proposed spkg at #6586.

"Proposed"? It's in Sage 4.2.alpha0.

Oops. I didn't know.

Some work needs to be done if you want to get rid of Jinja

For this ticket, I was thinking of just getting jinja2 in. We can do another ticket later for removing jinja. I'll close this since it's already done.

comment:3 follow-up: Changed 10 years ago by mhansen

  • Resolution fixed deleted
  • Status changed from closed to new

Actually, the notebook hasn't switched over. The only thing in Sage 4.2 that uses Jinja2 is Sphinx.

comment:4 in reply to: ↑ 3 Changed 10 years ago by ddrake

Replying to mhansen:

Actually, the notebook hasn't switched over. The only thing in Sage 4.2 that uses Jinja2 is Sphinx.

This ticket isn't about switching anything to Jinja2. The title is "include jinja2 / upgrade jinja spkg", and I closed it because you had already done exactly that in 4.2.alpha0.

#7249 is about switching, and it has a patch and awaits review.

comment:5 Changed 10 years ago by mhansen

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6586.

Note: See TracTickets for help on using tickets.