Opened 11 years ago

Closed 11 years ago

#7242 closed task (duplicate)

Convert sage to use the new standard libary multiprocessing module rather than processing

Reported by: tabbott Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I notice that sage is still including the Python processing module. It seems that in Python 2.6, a version of the processing module was merged into the Python standard library under the name "multiprocessing". I am told that it should be possible to convert by just replacing the references to processing with new ones to multiprocessing.

See <http://www.python.org/dev/peps/pep-0371/>

We should then be able to drop the "processing" spkg.

Change History (1)

comment:1 Changed 11 years ago by mhansen

  • Milestone set to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6503. I'll get to this today.

Note: See TracTickets for help on using tickets.