Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7233 closed enhancement (duplicate)

[Closed as Duplicate to #6138] adapted SymmetricGroupAlgebra to the category framework

Reported by: hivert Owned by: nthiery
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords: Symmetric Group Algebra, Categories
Cc: combinat Merged in:
Authors: Nicolas M. Thiéry Reviewers: Florent Hivert
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The goal of the patch is to adapt SymmetricGroupAlgebra? to categories and to add some improvements. The patch improve SymmetricGroupAlgebra? in two ways:

  • When creating SGA(n) a coercion from SGA(n-1) is declared.

I'm submitting the patch on behalf on Nicolas after reviewing it.

Depends on the categories framework #5891.

Cheers,

Florent

Attachments (1)

categories-symmetric_group_algebra-6138-nt.patch (10.7 KB) - added by hivert 11 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 11 years ago by hivert

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from [with patch, positive review] adapted SymmetricGroupAlgebra to the category framework to [Closed as Duplicate to #6138] adapted SymmetricGroupAlgebra to the category framework

Oops !!! This is a duplicate of 6138... I should have gessed it from the name of the patch. Sorry for the mess,

Florent

comment:2 Changed 11 years ago by mhansen

  • Milestone changed from sage-4.2 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.