Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#7144 closed enhancement (duplicate)

desolve does not use contrib_ode

Reported by: robert.marik Owned by: burcin
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: calculus Keywords:
Cc: Merged in:
Authors: robert.marik Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by robert.marik)

The following code fails

y=function('y',x)
eqn=x*diff(y,x)^2-(1+x*y)*diff(y,x)+y == 0
desolve(eqn,y)

However, Maxima is able to produce the solution using contrib_ode command. If ode2 fails, Sage should call contrib_ode

maxima commands

load('contrib_ode)$
eqn:x*'diff(y,x)^2-(1+x*y)*'diff(y,x)+y=0;
contrib_ode(eqn,y,x);

will (hope) solved in few days together with 6479 which was supposed to be fixed, but needs more work. http://trac.sagemath.org/sage_trac/ticket/6479

Change History (2)

comment:1 Changed 12 years ago by robert.marik

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 11 years ago by mvngu

  • Milestone changed from sage-4.2 to sage-duplicate/invalid/wontfix

Closed as duplicate of #6479.

Note: See TracTickets for help on using tickets.