Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#7101 closed defect (duplicate)

Inconsistency in polynomial ring creation.

Reported by: hivert Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Hi sage developers,

I need to play with polynomials on various kind of coefficients. So I tried the following:

----------------------------------------------------------------------
| Sage Version 4.1.1, Release Date: 2009-08-14                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
Loading Sage library. Current Mercurial branch is: combinat
sage: R=QQ[x]
sage: R(1+x)
x + 1
sage: R=ZZ[x]
sage: R(1+x)
x + 1
sage: R=RealField(200)[x]
sage: R(1+x)
---------------------------------------------------------------------------
TypeError                                 Traceback (most recent call last)
[...]
TypeError: x is not a variable of Univariate Polynomial Ring in x over Real Field with 200 bits of precision

As mvngu pointed out on irc: the following works

sage: R.<x> = RealField(20)["x"]
sage: R(1 + x)
1.0000*x + 1.0000

But this is not very beautiful and worse it is very inconsistent... At least the error message should be more understandable...

What should we do about it ?

Cheers,

Florent

Change History (3)

comment:1 Changed 12 years ago by mhansen

This is fixed by the patches at #7007 and #5639.

comment:2 Changed 12 years ago by mhansen

  • Resolution set to duplicate
  • Status changed from new to closed

Err, it's a duplicate of #5755 which has been fixed.

comment:3 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.2 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.