Opened 12 years ago

Closed 6 years ago

Last modified 6 years ago

#7039 closed defect (fixed)

zn_poly-0.9 uses gcc, irrespective of setting of CC

Reported by: drkirkby Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: GNUism
Cc: david.kirkby@… Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by ltw)

Some time ago I sorted out the fact that znpoly failed to build if the linker used was the Sun linker, as znpoly used GNU specific flags.

I'm using

  • Solaris 10 update 7 on SPARC
  • sage-4.1.2.alpha2
  • Sun Studio 12.1
  • An updated configure script to allow the Sun compiler to be used #7021

Well it seems there was another defect too, as the setting of CC is ignored too.

zn_poly-0.9.p1/src/src/ks_support.c
Finished extraction
****************************************************
Host system
uname -a:
SunOS swan 5.10 Generic_139555-08 sun4u sparc SUNW,Sun-Blade-1000
****************************************************
****************************************************
CC Version
/opt/xxxsunstudio12.1/bin/cc -v
usage: cc [ options] files.  Use 'cc -flags' for details
****************************************************
make[2]: Entering directory `/export/home/drkirkby/sage/gcc32/sage-4.1.2.alpha2/spkg/build/zn_poly-0.9.p1/src'
gcc -fPIC -O3 -L. -I/export/home/drkirkby/sage/gcc32/sage-4.1.2.alpha2/local/include -I./include -DNDEBUG -o src/array.o -c src/array.c

Change History (14)

comment:1 Changed 12 years ago by drkirkby

  • Description modified (diff)

comment:2 Changed 12 years ago by drkirkby

  • Cc david.kirkby@… added
  • Report Upstream set to N/A

comment:3 Changed 10 years ago by ltw

  • Description modified (diff)

comment:4 Changed 9 years ago by Snark

At ticket #12433, I ask about writing an autotools build system for zn_poly and push it upstream. Wouldn't that fix that report too?

comment:5 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:6 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:7 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:8 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:9 Changed 6 years ago by jdemeyer

  • Component changed from build to packages: standard

comment:10 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #12433.

comment:11 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:12 Changed 6 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:13 Changed 6 years ago by drkirkby

Should this not be "wont fix"?

This almost automatic setting

new -> needs_review need_review to positive review positive_review to closed.

is in my opinion a bad thing.

comment:14 Changed 6 years ago by jhpalmieri

It looks like it is "won't fix": look at the ticket's "milestone".

Note: See TracTickets for help on using tickets.