Opened 12 years ago

Closed 7 years ago

#7024 closed defect (worksforme)

Flint ignores CC and CXX.

Reported by: drkirkby Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: jpflori Merged in:
Authors: Reviewers: R. Andrew Ohana, Leif Leonhardy
Report Upstream: Completely fixed; Fix reported upstream Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by ohanar)

Flitn 1.3.0.p2 is one of several programs which ignores the settings of CC and CXX and users a gcc and g++ that it finds.

flint-1.3.0.p2/src/profiler.h
flint-1.3.0.p2/src/mpn_extras-test.c
Finished extraction
****************************************************
Host system
uname -a:
SunOS swan 5.10 Generic_139555-08 sun4u sparc SUNW,Sun-Blade-1000
****************************************************
****************************************************
CC Version
/opt/xxxsunstudio12.1/bin/cc -v
usage: cc [ options] files.  Use 'cc -flags' for details
****************************************************
Found gcc 4 or later
Turning off loop unrolling on Solaris/Sparc
make[2]: Entering directory `/export/home/drkirkby/sage/gcc32/sage-4.1.2.alpha2/spkg/build/flint-1.3.0.p2/src'
gcc -std=c99 -I/export/home/drkirkby/sage/gcc32/sage-4.1.2.alpha2/local/include/ -I/export/home/drkirkby/sage/gcc32/sage-4.1.2.alpha2/local/include  -fPIC  -O2  -DNDEBUG -o zn_mod.o -c zn_poly/src/zn_mod.c

This needs fixing to add support for the Sun Studio compilers.

spkg: http://wstein.org/home/ohanar/clang-port/sage-5.0.beta1-src/spkg/standard/flint-1.5.0.p11.spkg

Attachments (1)

flint-1.5.0.p11.patch (1.2 KB) - added by ohanar 9 years ago.
for review purposes

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by mvngu

See ticket #6919 for an updated FLINT spkg.

comment:2 Changed 11 years ago by drkirkby

  • Report Upstream set to Reported upstream. Developers acknowledge bug.

Bill Hart reported on 27th September that:

I've added this to a FLINT todo list and will attend to it in the next release.

Thanks for mentioning it.

Bill.

I will chase this up, to find out if it is fixed or not.

comment:3 Changed 9 years ago by ohanar

  • Authors set to R. Andrew Ohana
  • Description modified (diff)
  • Status changed from new to needs_review

Changed 9 years ago by ohanar

for review purposes

comment:4 Changed 9 years ago by leif

  • Reviewers set to Leif Leonhardy
  • Status changed from needs_review to needs_work

$CC and $CXX have to be quoted.

Note that the issue is (at least partially) fixed upstream in FLINT 1.5.2 IIRC; I already made an spkg with various other changes (including the Makefile) a while ago btw. ... (cf. discussion at #9858)

comment:5 Changed 9 years ago by jpflori

  • Cc jpflori added

comment:6 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:7 Changed 7 years ago by jdemeyer

  • Authors R. Andrew Ohana deleted
  • Milestone changed from sage-5.13 to sage-duplicate/invalid/wontfix
  • Report Upstream changed from Reported upstream. Developers acknowledge bug. to Completely fixed; Fix reported upstream
  • Resolution set to worksforme
  • Reviewers changed from Leif Leonhardy to R. Andrew Ohana, Leif Leonhardy
  • Status changed from needs_work to closed

Works with the newer FLINT 2.x

Note: See TracTickets for help on using tickets.