Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#6991 closed defect (duplicate)

lattice polytope nfacets method broken for non-reflexive polytopes

Reported by: mhampton Owned by: mhampton
Priority: trivial Milestone: sage-duplicate/invalid/wontfix
Component: geometry Keywords:
Cc: novoselt Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In the nfacets method, for non-reflexive lattice polytopes this is computed from:

self._nfacets = len(self._facet_normals)

but self._facet_normals is a matrix, which does not have a len method. So I think this should instead be

self._nfacets = self._facet_normals.nrows()

A doctest should also be added for this case.

Change History (5)

comment:1 Changed 12 years ago by novoselt

This is actually fixed by this patch (which needs a review):

http://trac.sagemath.org/sage_trac/ticket/6778

comment:2 Changed 12 years ago by mhampton

  • Priority changed from minor to trivial

OK, sorry about that. I am working through your tickets and I should have looked more closely. This ticket can be closed as a duplicate of 6778.

-Marshall

comment:3 Changed 11 years ago by novoselt

  • Report Upstream set to N/A
  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 11 years ago by mhansen

  • Milestone changed from sage-4.3.1 to sage-feature

comment:5 Changed 11 years ago by mhansen

  • Milestone changed from sage-feature to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.