Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#6951 closed defect (fixed)

[with spkg, positive review] Singular fails to build on t2.math with GCC

Reported by: mvngu Owned by: mabshoff
Priority: major Milestone: sage-4.1.2
Component: packages: standard Keywords:
Cc: malb, drkirkby Merged in: Sage 4.1.2.alpha4
Authors: Georg S. Weber Reviewers: Minh Van Nguyen
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

As the subject says. I have attached an install log of Sage 4.1.2.alpha1, building on t2.math with GCC 4.4.1.

Attachments (1)

install-4.1.2.alpha1-t2.math.log.bz2 (670.3 KB) - added by mvngu 13 years ago.
install log for Sage 4.1.2.alpha1 on t2.math with GCC 4.4.1

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by mvngu

install log for Sage 4.1.2.alpha1 on t2.math with GCC 4.4.1

comment:1 Changed 13 years ago by malb

  • Cc drkirkby added

Here is the relevant portion:

for file in *.h; do \
../.././install-sh -c $file /scratch/mvngu/sage-4.1.2.alpha1-6945-readline-cliquer-ecl/local/include/singular; \
done
/bin/sh: ../.././install-sh: not found

IIRC Dave fixed this before but I must have missed to include his fix (the update was a bit chaotic because quite a few fixed from different people went in). David, would you mind reminding me how to fix this?

comment:2 Changed 13 years ago by GeorgSWeber

Briefly, we're missing a file "install-sh" for Sun, and possibly a switch change from -O2 to -O0 on Itanium; copied from my post at the sage-devel thread: Hi Minh,

obviously (look at your own trace output), you are talking about "singular-3-1-0-4-20090818.spkg", not "singular-3-1-0-4-20090723.spkg".

Just looking at the top entries of the "SPKG.txt" file of the old (Sage-4.1.1) "singular-3-1-0-2-20090620.p0.spkg", and of the current Sage-4.1.2-alpha "singular-3-1-0-4-20090818.spkg", shows what the problem is, that the latter spkg might be broken also on Itanium (ia64, see trac #6360 and #6240) i.e. not only on Sun, and what to do about it. I can look into building a new spkg with the necessary fixes tomorrow, or the day after, if nobody beats me to it.

Cheers, Georg

comment:3 Changed 13 years ago by GeorgSWeber

  • Authors set to Georg S. Weber
  • Summary changed from Singular fails to build on t2.math with GCC to [with spkg, needs review] Singular fails to build on t2.math with GCC

comment:4 Changed 13 years ago by mvngu

  • Merged in set to Sage 4.1.2.alpha3
  • Resolution set to fixed
  • Reviewers set to Minh Van Nguyen
  • Status changed from new to closed
  • Summary changed from [with spkg, needs review] Singular fails to build on t2.math with GCC to [with spkg, positive review] Singular fails to build on t2.math with GCC

See my report at #6849. Also builds on t2.math. Now the compilation on t2.math fails when building the package sage-4.1.2.alpha2.spkg. Positive review.

comment:5 Changed 13 years ago by mvngu

  • Merged in changed from Sage 4.1.2.alpha3 to Sage 4.1.2.alpha4

There is no 4.1.2.alpha3. Sage 4.1.2.alpha3 was William Stein's release for working on making the notebook a standalone package.

Note: See TracTickets for help on using tickets.