Opened 10 years ago

Closed 10 years ago

#6920 closed defect (fixed)

irreducible components function is stupid in case of projective space

Reported by: was Owned by: was
Priority: major Milestone: sage-4.3.2
Component: algebraic geometry Keywords:
Cc: Merged in: sage-4.3.2.alpha0
Authors: William Stein Reviewers: Alex Ghitza
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I just ran the following on sagenb.org (so the latest release):

PP.<x,y,z,w> = ProjectiveSpace(3,QQ)
f = x^3 + y^3 + z^3 + w^3
R = f.parent()
I = [f] + [f.derivative(zz) for zz in PP.gens()]
V = PP.subscheme(I)
V.irreducible_components()

The output is:



[
Closed subscheme of Projective Space of dimension 3 over Rational
Field
defined by:
 w
 z
 y
 x
]

[
Closed subscheme of Projective Space of dimension 3 over Rational
Field defined by:
 w
 z
 y
 x
]


I think that the problem is that normally Proj(R) is defined to be all
prime ideals that do not contain

sum_{d > 0} S_d

where R is a graded ring graded by non-negative integers, and S_d is
the ideal generated by homogeneous elements of degree d.  I glanced at
irreducible_components and it just returns all of the prime ideals
coming from the primary decomposition.  In the case that the ambient
scheme is projective, it should exclude some.

Victor Miller

P.S. I wrote this code, so I think it's OK for me to call this stupid. -- William

Attachments (1)

trac_6920.patch (5.7 KB) - added by was 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by was

comment:1 Changed 10 years ago by wjp

  • Report Upstream set to N/A
  • Status changed from new to needs_review

comment:2 Changed 10 years ago by AlexGhitza

  • Authors set to William Stein
  • Reviewers set to Alex Ghitza
  • Status changed from needs_review to positive_review

Looks good.

comment:3 Changed 10 years ago by mvngu

  • Merged in set to sage-4.3.2.alpha0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.