Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6815 closed defect (fixed)

Restarting worksheet doesn't enable typesetting even when "Typeset" box is checked

Reported by: gmhossain Owned by: boothby
Priority: major Milestone: sage-4.3
Component: notebook Keywords:
Cc: was, mpatel Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Restarting worksheet seems to disable latex typesetting even though "Typeset" box is checked. If I un-check and then re-check the "Typeset" box, it starts working again.

Change History (6)

comment:1 follow-up: Changed 10 years ago by jhpalmieri

Either I don't understand the problem, or I'm not having it. What Sage version, browser, and OS?

Here's what I did (Sage 4.1.1 on a Mac (Intel, OS X 10.5) with Safari or Firefox): I start a worksheet, click the Typeset box, then do some stuff.

Then I can (a) close the worksheet window, (b) click the "Save & quit" button then close it, or (c) quit Sage, leaving the window open. After doing (a) or (b) and re-opening the worksheet, or doing (c) and running 'sage -notebook', then when I evaluate a cell in the worksheet, latex typesetting is still active.

comment:2 in reply to: ↑ 1 Changed 10 years ago by gmhossain

Replying to jhpalmieri:

Either I don't understand the problem, or I'm not having it. What Sage version, browser, and OS?


I am having this issue with Sage-4.1.1 in Ubuntu 9.04 (Thinkpad x61-tablet) with both Firefox/Google? Chrome. I guess, you might see this issue if you restart the worksheet (Action-->Restart Worksheet).

comment:3 Changed 10 years ago by timdumol

  • Cc was mpatel added

I cannot reproduce this issue in Sage-4.1.2 using sagenb-0.4. Can someone please confirm, and if so, close this ticket?

comment:4 Changed 10 years ago by jhpalmieri

  • Report Upstream set to N/A

I don't see this any more, either. Can we close it?

comment:5 Changed 10 years ago by was

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 10 years ago by mvngu

  • Milestone set to sage-4.3
Note: See TracTickets for help on using tickets.