Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6791 closed defect (duplicate)

2 doctest failures in devel/sage/sage/symbolic/expression.pyx

Reported by: drkirkby Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On Solaris 10 update 7 (SPARC), the following tests failed. Both ECL and Maxima were updated - ECL version 9.8.4, Maxima version 5.19.1. Sage was built with gcc 4.4.1

----------------------------------------------------------------------
| Sage Version 4.1.1, Release Date: 2009-08-14                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
Thu Aug 20 20:02:37 BST 2009
dsage-trial tmp directory doesn't exist - creating ...
This script will run the unit tests for DSage

<SNIP>

**********************************************************************
File "/export/home/drkirkby/sage/sage-4.1.1/devel/sage/sage/symbolic/expression.pyx", line 5541:
    sage: solve(Q*sqrt(Q^2 + 2) - 1,Q)
Expected:
    [Q == 1/sqrt(-sqrt(2) + 1), Q == 1/sqrt(sqrt(2) + 1)]
Got:
    [Q == 1/sqrt(sqrt(2) + 1)]
**********************************************************************
File "/export/home/drkirkby/sage/sage-4.1.1/devel/sage/sage/symbolic/expression.pyx", line 2467:
    sage: sin(x/2).expand_trig(half_angles=True)
Expected:
    1/2*sqrt(-cos(x) + 1)*sqrt(2)
Got:
    1/2*sqrt(-cos(x) + 1)*sqrt(2)*(-1)^floor(1/2*x/pi)
**********************************************************************
2 items had failures:
   1 of   6 in __main__.example_138
   1 of  13 in __main__.example_61
***Test Failed*** 2 failures.

Change History (4)

comment:1 Changed 12 years ago by AlexGhitza

Duplicate of #6789.

comment:2 Changed 12 years ago by kcrisman

To release manager: Sounds like this should be closed, then.

comment:3 Changed 12 years ago by was

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.2 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.