Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6746 closed defect (duplicate)

cliquer doesn't build under 64-bit mode

Reported by: mvngu Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: jhpalmieri, ncohen Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

At this sage-devel thread, Kiran Kedlaya reported a problem with building cliquer under a 64-bit platform:

On 64-bit Fedora 10, I get a build failure in cliquer. The relevant
snippet from the install log is below.

This looks like a case of 32/64 confusion, which I am no stranger to.
This machine runs on a primarily 32-bit network, and in the past we've
discovered various build problems due to this. For instance, the local
gcc in /usr/bin is 64-bit, but the NFS one in /usr/local/bin is 32-
bit, so I have to configure my path appropriately. In this case, it's
somehow trying to find stubs-32.h instead of stubs-64.h, but I don't
know why.

John Palmieri also reported at ticket #6681 a similar problem with 64-bit OS X.

Change History (4)

comment:1 follow-up: Changed 12 years ago by mvngu

See ticket #6681 for an updated cliquer spkg. If that package also builds on 64-bit Fedora 10, then this ticket should be closed as a duplicate of #6681.

comment:2 in reply to: ↑ 1 Changed 12 years ago by kedlaya

Replying to mvngu:

See ticket #6681 for an updated cliquer spkg. If that package also builds on 64-bit Fedora 10, then this ticket should be closed as a duplicate of #6681.

It does indeed build on 64-bit Fedora 10, as part of a full build of 4.1.2.alpha2.

comment:3 Changed 12 years ago by mhansen

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6681

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.2 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.