Opened 8 years ago

Closed 5 years ago

#6654 closed enhancement (fixed)

New features in group algebra category

Reported by: vferay Owned by: mhansen
Priority: major Milestone: sage-5.4
Component: combinatorics Keywords: group algebra, center
Cc: Merged in: sage-5.4.beta1
Authors: Valentin Féray Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by chapoton)

I added features in the category of group algebras (especially linked to the center).

Moreover, the symmetric group algebra now is a parent of this category.

Note : I have folded it with a previous patch on the same features, so look at the new version of the file (sorry, I should have worked on the same patch since the beginning)

Apply group_algebras_feature_central_vf.v2.patch

Attachments (1)

group_algebras_feature_central_vf.v2.patch (17.8 KB) - added by chapoton 5 years ago.
clean up of doc

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by wdj

  • Summary changed from [with patch, needs review] new features in group algebra category to [with patch, needs work] new features in group algebra category

This patch failed to pply for me:

----------------------------------------------------------------------
| Sage Version 4.1.1.rc2, Release Date: 2009-08-06                   |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
**********************************************************************
*                                                                    *
* Warning: this is a prerelease version, and it may be unstable.     *
*                                                                    *
**********************************************************************
Loading Sage library. Current Mercurial branch is: gpalg
sage: hg_sage.apply("/Users/davidjoyner/sagefiles/grotrac_6647_permutationgroup_improvement.patch")
/Users/davidjoyner/sagefiles/group_algebras_feature_central_vf.patch
/Users/davidjoyner/sagefiles/groups
sage: hg_sage.apply("/Users/davidjoyner/sagefiles/group_algebras_feature_central_vf.patch")cd "/Users/davidjoyner/sagefiles/sage-4.1.1.rc2/devel/sage" && hg status
/Users/davidjoyner/sagefiles/sage-4.1.1.rc2/local/lib/python2.6/site-packages/sage/misc/hg.py:240: DeprecationWarning: os.popen3 is deprecated.  Use the subprocess module.
  x = os.popen3(s)
cd "/Users/davidjoyner/sagefiles/sage-4.1.1.rc2/devel/sage" && hg status
cd "/Users/davidjoyner/sagefiles/sage-4.1.1.rc2/devel/sage" && hg import   "/Users/davidjoyner/sagefiles/group_algebras_feature_central_vf.patch"
applying /Users/davidjoyner/sagefiles/group_algebras_feature_central_vf.patch
unable to find 'sage/categories/group_algebras.py' for patching
3 out of 3 hunks FAILED -- saving rejects to file sage/categories/group_algebras.py.rej
unable to find 'sage/categories/monoid_algebras.py' for patching
1 out of 1 hunks FAILED -- saving rejects to file sage/categories/monoid_algebras.py.rej
patching file sage/combinat/symmetric_group_algebra.py
Hunk #2 FAILED at 121
Hunk #3 FAILED at 131
Hunk #5 FAILED at 430
3 out of 5 hunks FAILED -- saving rejects to file sage/combinat/symmetric_group_algebra.py.rej
abort: patch failed to apply

DO you know what the problem is?

comment:2 Changed 8 years ago by vferay

  • Description modified (diff)
  • Summary changed from [with patch, needs work] new features in group algebra category to [with patch, needs review] new features in group algebra category

This patch must be applied after Nicolas Thiéry's patches on categories (I do not know which one exactly). So please do not use import to test it but apply it with qpush.

comment:3 Changed 7 years ago by vferay

  • Status changed from needs_review to needs_work
  • Summary changed from [with patch, needs review] new features in group algebra category to [with patch, needs work] new features in group algebra category

comment:4 Changed 5 years ago by chapoton

  • Description modified (diff)
  • Report Upstream set to N/A

comment:5 Changed 5 years ago by chapoton

  • Description modified (diff)
  • Status changed from needs_work to needs_review

apply only group_algebras_feature_central_vf.v2.patch

comment:6 Changed 5 years ago by chapoton

apply only group_algebras_feature_central_vf.v2.patch

Changed 5 years ago by chapoton

clean up of doc

comment:7 Changed 5 years ago by chapoton

apply only group_algebras_feature_central_vf.v2.patch

comment:8 Changed 5 years ago by chapoton

  • Milestone changed from sage-5.3 to sage-5.4
  • Reviewers set to Frédéric Chapoton
  • Status changed from needs_review to positive_review

Given that the bot is happy, and that I have done my best to check the doc, I give a positive review.

comment:9 Changed 5 years ago by jdemeyer

  • Summary changed from [with patch, needs work] new features in group algebra category to New features in group algebra category

comment:10 Changed 5 years ago by jdemeyer

  • Merged in set to sage-5.4.beta1
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.