Opened 12 years ago

Closed 7 years ago

#6610 closed enhancement (duplicate)

Compiler environment variables should be consistent

Reported by: ghtdak Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords: Environment
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Sage sets the environment variable LIBRARY_PATH which is a gcc variable. OTOH, it doesn't set CPATH or C_INCLUDE_PATH or CPLUS_INCLUDE_PATH. This causes inconsistencies, particularly since Sage replicates many Linux libraries potentially leading to version issues.

LD_LIBRARY_PATH is also set (appended / modified), as it would need to be, but that is for the loader (ld). Sometimes this leads to difficulties when running non-Sage installed executables which use replicated libraries. One example is Git which doesn't like Sage's zlib.

This latter problem is more difficult to address and rarely causes difficulty. In fact, the only manifestation I've seen is git although it seems obvious that there are potential problems lurking.

In my case, I replace the symlinks for libz.so* to reference the system libraries. This will work as long as major version's (interfaces) are consistent.

Change History (3)

comment:1 in reply to: ↑ description Changed 7 years ago by jdemeyer

  • Milestone set to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

This is essentially a duplicate of #10572.

comment:2 Changed 7 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:3 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.