Opened 12 years ago

Closed 9 years ago

#6582 closed defect (duplicate)

Potential issue in polybori - 0.5rc.p8 and/or 0.5rc.p9

Reported by: drkirkby Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: porting: Solaris Keywords:
Cc: AlexanderDreyer, PolyBoRi, david.kirkby@… Merged in:
Authors: Reviewers: Alexander Dreyer
Report Upstream: Completely fixed; Fix reported upstream Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by AlexanderDreyer)

I believe there is an issue which *may* affect Solaris with polybori 0.5rc.p8, and assuming my patch to .p9 gets positive review, will affect that too, as I have not tried to fix this.

Here are some notes I put in patches/custom.py

# Note, these 'SAGE_DEBUG' linker flags added by someone
# are likely to break if used on Solaris
# with the Sun linker, as -p option to the Sun linker is:
#         [-p auditlib]   identify audit library to accompany this object
# This has not been confirmed, and I don't have time to test it.
# David Kirkby, 21st July 2009. I suggest this is revisited by someone soon.
if os.environ.has_key('SAGE_DEBUG'):
    CPPDEFINES=[]
    CCFLAGS=[" -pg"] + CCFLAGS
    CXXFLAGS=[" -pg"] + CXXFLAGS
    LINKFLAGS=[" -pg"]



Duplicate of #11575.

Change History (9)

comment:1 Changed 12 years ago by drkirkby

  • Milestone changed from sage-4.1.2 to sage-4.1.3

Another issue, which is this case I am 100% sure about, is that PolyBoRi? (as of polybori-0.6.3-20090827.spkg) in sage-4.1.2.alpha4 is that PolyBoRi? is sending GNU-specific options to the Sun compiler. See #7034

comment:2 Changed 11 years ago by drkirkby

  • Cc polybori-discuss@… david.kirkby@… added
  • Report Upstream set to N/A

comment:3 Changed 9 years ago by jdemeyer

Is this still a problem?

comment:4 Changed 9 years ago by AlexanderDreyer

  • Cc AlexanderDreyer PolyBoRi added; polybori-discuss@… removed
  • Report Upstream changed from N/A to Completely fixed; Fix reported upstream

No, it was fixed. For instance, in #12655 for PolyBoRi 0.8.1.

comment:5 Changed 9 years ago by AlexanderDreyer

  • Description modified (diff)
  • Status changed from new to needs_review

Duplicate of#12655.

comment:6 Changed 9 years ago by AlexanderDreyer

  • Status changed from needs_review to positive_review

Abusing "positive review".

comment:7 follow-up: Changed 9 years ago by jdemeyer

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Reviewers set to Alexander Dreyer

In such cases, you should set the milestone to "sage-duplicate/invalid/wontfix".

comment:8 in reply to: ↑ 7 Changed 9 years ago by AlexanderDreyer

Replying to jdemeyer:

In such cases, you should set the milestone to "sage-duplicate/invalid/wontfix".

Thanks, I'll do so next time.

comment:9 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.