Opened 12 years ago

Closed 12 years ago

#6562 closed defect (duplicate)

Unicode support in TextCells

Reported by: mora Owned by: boothby
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords: textcell unicode
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In a TextCell? (shift+click on the blue line) I write some letters:

http://www.math.bme.hu/~morap/sage_textcell1.png

after I save it. It looks fine:

http://www.math.bme.hu/~morap/sage_textcell2.png

but when I double click on it to edit, then I get:

http://www.math.bme.hu/~morap/sage_textcell3.png

That's the problem. I could not find out what (Python or TinyMCE) converts the special characters to html entities (for example é to é), but it does not convert all of them.

The patch solves the problem. Without it the html code looks like:

http://www.math.bme.hu/~morap/sage_textcell4.png

using the patch everything's fine. The html code after applying the patch:

http://www.math.bme.hu/~morap/sage_textcell5.png

Attachments (1)

12659.patch (721 bytes) - added by mora 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by mora

comment:1 Changed 12 years ago by mora

  • Milestone set to sage-4.1.1

comment:2 Changed 12 years ago by mora

The Ticket 6464 is nearly the same. I suggest the solution of 6464 to use.

comment:3 Changed 12 years ago by kcrisman

To release manager: this should be closed as a duplicate of #6464, as mentioned above.

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from [with patch, needs review] Unicode support in TextCells to Unicode support in TextCells

Closing this as a duplicate of #6464.

Note: See TracTickets for help on using tickets.