Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#6485 closed defect (fixed)

[with patch, positive review] broken links from website index to tutorial, constructions, etc.

Reported by: mpatel Owned by: tba
Priority: minor Milestone: sage-4.1.1
Component: documentation Keywords:
Cc: Merged in: sage-4.1.1.alpha0
Authors: Mitesh Patel Reviewers: David Loeffler
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Build the HTML documentation, including the website, and navigate to $SAGE_ROOT/devel/sage/doc/output/html/en/index.html. Clicking on a link to an individual document yields a directory listing, instead of the expected index page.

Attachments (1)

trac_6485_website_links.patch (3.6 KB) - added by mpatel 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by mpatel

comment:1 Changed 13 years ago by davidloeffler

This ticket looks like a duplicate of #5550 to me. Since mpatel's already uploaded a patch here, I suggest we close #5550 as a duplicate and keep this one open.

comment:2 Changed 13 years ago by davidloeffler

  • Reviewers set to David Loeffler
  • Summary changed from [with patch, needs review] broken links from website index to tutorial, constructions, etc. to [with patch, positive review] broken links from website index to tutorial, constructions, etc.

Works for me.

comment:3 Changed 13 years ago by davidloeffler

  • Milestone set to sage-4.1.1

comment:4 Changed 13 years ago by mvngu

  • Merged in set to sage-4.1.1.alpha0
  • Resolution set to fixed
  • Status changed from new to closed

The patch fixes the index.html linking problem, but only for the page

SAGE_ROOT/devel/sage/doc/output/html/en/index.html

There's also a "website" which can be built using

sage -docbuild website html

and the same problem is still with the page

SAGE_ROOT/devel/sage/doc/output/html/en/website/index.html

But I doubt we need "website" at all. Its purpose is to link to the other 8 standard documents. This is already achieved with

SAGE_ROOT/devel/sage/doc/output/html/en/index.html

So I'm closing this ticket as fixing the linking problem in the page

SAGE_ROOT/devel/sage/doc/output/html/en/index.html

Feel free to open another ticket to fix or delete the "website" page.

comment:5 Changed 13 years ago by mpatel

I think sage -docbuild website html builds the top-level index.html in website/ and just copies the output up one directory level. (We could delete the original afterward.) Perhaps I should have put "web site" in the summary instead of "website." I apologize, if I'm mistaken.

Note: See TracTickets for help on using tickets.