Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6481 closed defect (duplicate)

g.subs({x:1,y:2}) should walk through x,y sorted

Reported by: malb Owned by: malb
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

reported by Kwankyu on [sage-support]:

I mean the substitution y:x*y is applied first in the following

sage: R.<x,y>=QQ[]
sage: g=x+y
sage: g.subs({x:x+1,y:x*y})
x*y + x + y + 1

where I think applying x:x+1 first seems intuitive if order ever
should be significant.

Change History (4)

comment:1 Changed 12 years ago by was

For the record, I think the entire design of subs for multivariate polynomial rings is wrong. I've thus opened #6482 and explained my reasoning for this.

Note that in any case, if the current subs behavior is super fast or useful to people (is it?) then we can keep it as a nondefault option, in which case this ticket #6481 also makes sense to keep, since at least we should do the order of substitution in an easy-to-understand way.

comment:2 Changed 12 years ago by rlm

  • Milestone changed from sage-4.1 to sage-4.1.1

comment:3 Changed 12 years ago by malb

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #6482

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.2 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.