Opened 12 years ago

Closed 12 years ago

#6383 closed defect (duplicate)

implement additive_order for points on an elliptic curve

Reported by: was Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This should work:

sage: E = EllipticCurve('11a'); P = E.torsion_subgroup().gens()[0]; P
(5 : 5 : 1)
sage: P.additive_order()
---------------------------------------------------------------------------
NotImplementedError                       Traceback (most recent call last)

/Users/wstein/.sage/temp/resid_tg105.upc.es/5930/_Users_wstein__sage_init_sage_0.py in <module>()

/Users/wstein/build/sage/local/lib/python2.5/site-packages/sage/structure/element.so in sage.structure.element.ModuleElement.additive_order (sage/structure/element.c:8113)()

NotImplementedError: 
sage: P.order()
5

Change History (2)

comment:1 Changed 12 years ago by davidloeffler

  • Milestone changed from sage-4.1 to sage-duplicate/invalid/wontfix

This seems to be a duplicate of #6382.

comment:2 Changed 12 years ago by rlm

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.