Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#6382 closed defect (duplicate)

implement additive_order for points on an elliptic curve

Reported by: was Owned by: davidloeffler
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: elliptic curves Keywords:
Cc: mhansen, mvngu Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This should work:

sage: E = EllipticCurve('11a'); P = E.torsion_subgroup().gens()[0]; P
(5 : 5 : 1)
sage: P.additive_order()
---------------------------------------------------------------------------
NotImplementedError                       Traceback (most recent call last)

/Users/wstein/.sage/temp/resid_tg105.upc.es/5930/_Users_wstein__sage_init_sage_0.py in <module>()

/Users/wstein/build/sage/local/lib/python2.5/site-packages/sage/structure/element.so in sage.structure.element.ModuleElement.additive_order (sage/structure/element.c:8113)()

NotImplementedError: 
sage: P.order()
5

Change History (7)

comment:1 Changed 12 years ago by davidloeffler

  • Component changed from number theory to elliptic curves
  • Owner changed from was to davidloeffler

comment:2 Changed 12 years ago by cremona

This is a duplicate of #3108 whic hhas a patch waiting review. This ticket can terefore be closed.

comment:3 Changed 12 years ago by cremona

  • Summary changed from implement additive_order for points on an elliptic curve to duplicate] implement additive_order for points on an elliptic curve

comment:4 Changed 12 years ago by cremona

  • Summary changed from duplicate] implement additive_order for points on an elliptic curve to [duplicate] implement additive_order for points on an elliptic curve

comment:5 Changed 12 years ago by jason

  • Cc mhansen mvngu added

Please note the request to close this.

comment:6 Changed 12 years ago by mhansen

  • Milestone changed from sage-4.1.3 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3108.

comment:7 Changed 11 years ago by mvngu

  • Summary changed from [duplicate] implement additive_order for points on an elliptic curve to implement additive_order for points on an elliptic curve
Note: See TracTickets for help on using tickets.