Opened 8 years ago

Closed 5 years ago

#6375 closed defect (duplicate)

Run sage once as part of install process to generate sage-flags.txt

Reported by: craigcitro Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

When sage runs for the first time, it creates a file sage-flags.txt to keep track of what special instructions the CPU supports. Several people have run into trouble compiling and installing sage as root, and then running it as a normal user, because they don't have permission to create the file. Here's such a traceback:

Traceback (most recent call last):
  File "/usr/local/sage-4.0.2/local/bin/sage-location", line 174, in <module>
    t, R = install_moved()
  File "/usr/local/sage-4.0.2/local/bin/sage-location", line 18, in install_moved
    write_flags_file()
  File "/usr/local/sage-4.0.2/local/bin/sage-location", line 82, in write_flags_file
    open(flags_file,'w').write(get_flags_info())
IOError: [Errno 13] Permission denied: '/usr/local/sage-4.0.2/local/lib/sage-flags.txt'

It would seem sensible to run local/bin/sage-starts once during the install process to create this file.

Change History (1)

comment:1 Changed 5 years ago by jdemeyer

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to closed

Duplicate of #11926.

Note: See TracTickets for help on using tickets.